龙芯俱乐部是由龙芯首批个人用户发起的龙芯爱好者社区。我们的成员来自五湖 四海、各行各业。目的是为了促进龙芯爱好者间的交流和龙芯的宣传。我们和开 源社区有着密切的联系,愿意和开源社区一道合作开创崭新的未来。我们欢迎任 何关心,喜欢龙芯的朋友加入到我们的行列里来,一起享受龙芯爱好者的乐趣。 注册用户与非注册用户,浏览下载权限是一样的, 如果想要发表文章, 请联系我开通帐号。有什么不能下载的也可以找我, gmail:liushiwei

龙芯2运行debian lenny 下 iceweasel 3.0.1崩溃问题.

这几天发现, iceweasel 3.0.1运行时崩溃, 在终端窗口下运行 iceweasel ,看到提示, 是

/usr/lib/gstreamer-0.10/libgstffmpeg.so  造成的.

检查这个文件属于 gstreamer0.10-ffmpeg包,

dpkg -S libgstffmpeg.so
gstreamer0.10-ffmpeg:/usr/lib/gstreamer-0.10/libgstffmpeg.so

然后卸掉它就行了.至于原因,以后再说.

 

gnome下修改网络配置

在gnome下修改网络配置, 使用的是gnome-network-admin这个包,

但是执行[系统]-[系统管理]-[网络],输入root口令后,出现错误提示:
"系统管理员不允许您访问系统配置。"

从po中找到英文原文是

"You are not allowed to access the system configuration." 

然后到google查找["You are not allowed to access the system configuration." gnome]

找到2个建议

1.需要把用户 加进admin用户组

  groupadd admin

debian下的农历插件

aptitude install lunar             lunar-applet

pkill gnome-panel

然后在面板添加

 

mplayer升级

debian里面的mplayer 在mipsel下,关闭了rmvb,需要修改debian源码包的 debian/rules文件。同时打开中文界面,用附件补丁,

apt-get source mplayer

cd mplayer-1.0~rc2

patch -p1 <../mplayer_loongson.patch

执行dch修改版本号从mplayer-1.0~rc2-16改成mplayer-1.0~rc2-16loongson

然后就可以编译了。

编译脚本:

u盘自动挂载

安装: aptitude install gnome-volume-manager gconf-editor gnome-mount

在gnome下,用gnome-volume-manager ,在gnome2.18以前是用pmount,gnome2.18以后,用的是gnome-mount

装gnome-volume-manager 后,

龙芯2F的内核 2.6.18.8

如果你想拿6002/3做网关, 或者扩展无线网卡, 或者做raid5,或者想试试ntfs-3g, nfs, smbfs,cifs, 或者你想试试openvpn,那么你需要安装bjlx源里面的这个包:

linux-image-2.6.18.8-loongson2f-v1.02a

 

华蕾的系统,可以下载安装:

 ftp://www.bjlx.org.cn/loongson2f/lenny/kernel

 

另外提供:header包,源码包.

 

今天打了几个patch ,升级到 2.6.18.8,

nfs模块完善了一下, 网卡驱动升级了一下,希望能够解决大流量ftp问题

第二次龙芯电脑用户交流


初步定于下周日7月27日,上下午,午餐AA,
地点暂定于安恒公司, 白石桥附近。
大家的龙芯电脑有问题的可以现场讨论。

龙芯2E的,2F的, 刷pmon刷成砖头的, 想升级pmon的, 想升级系统的,要做u盘的,
想看看怎么恢复系统的, 都可以现场交流解决.

 

报名的到

http://www.bjlx.org.cn/add.php 登记一下.

 

 

2008-07-15 龙芯2F的内核2.6.18v1.02和pmon r125

下载:ftp://www.bjlx.org.cn/loongson2f/r125.tar.gz

r125的pmon与2.6.18v1.02的内核必须配套更换.

把你的龙芯加入到全球联网的计算机集群中,我创建了一个loongson团队,大家加入吧

SETI@home 是一项利用全球联网的计算机共同搜寻地外文明的科学实验计划。你可以通过运行一个免费程序下载并分析从射电望远镜传来的数据来加入这个项目。

项目主页:http://setiathome.berkeley.edu/

盒子的用户,可以很简单的加入这个实验计划,,目前debian里带的程序,效率还比较低, 等过几天我们用龙芯指令重新编译后,会自动升级 

seti.jpg

loongson2f可以使用的u盘镜像

ftp://www.bjlx.org.cn/loongson2f/usb_loongson2f_v1.tar.bz2

在格式化u盘的时候, 要先确定u盘的设备号(/dev/sda1,或者 /dev/sdb1) , 可以插上u盘,通过dmesg来确认设备号,

如果u盘自动挂载了,要先卸载才可以格式化, 可以通过 df -h 看到设备号和挂载点,

准备就绪后,使用如下命令.

mkfs.ext3 -T small  /dev/sda?       (别格错了盘)

 

然后把文件展开到u盘

cd /home

wget  ftp://www.bjlx.org.cn/loongson2f/usb_loongson2f_v1.tar.bz2

pmon不能识别debian lenny的mkfs.ext3格式化出来的ext3分区的问题的解决

目前华镭已经修复这个问题, 下一版的pmon将解决这个问题。

在此之前,可以如下方法临时解决

修改 /etc/mke2fs.conf 把defaults下的inode_ratio从16384改到8192就行了。
原因是pmon不能识别inode_radio大于等于16384的ext3分区.



做u盘时, 用
mkfs.ext3 -T small /dev/sda1
可以自动使用小的族,提高存储的利用率, 并且使用 inode_radio=4096

目前盒子的 pmon的版本列表

版本主要通过 vers命令来看编译日期.

 

2E:

2006-12   最早的版本,2E出厂带的版本,  不支持32位内核, 不支持 512m内存 建议升级到1.1.2.1版

2007年的  2007年下半年带的版本,支持64位内核,支持256m以上的内存 建议升级到1.1.2.1版

收藏一篇文章 2e软超频方法

 

X档案-其实2E盒子也可以实现动态调节频率!

http://www.lemote.com/bbs/viewthread.php?tid=16061

eva升级 解决登录时崩溃问题

这个问题,存在很久了,今天的一次升级解决了这个问题。升级包已经放在源里,

upgrade就可以了

有需要源码包的可以在 源里找到。 直接下载也可以 

ftp://www.bjlx.org.cn/loongson2f/lenny/eva

 

mplayer

2008-06-12.重新编译了mplayer.  默认为zh_CN界面,并打开了real支持, 可以使用rmvb的2f解码库了, 2f的rmvb解码库, 见附件

通过我们的源update后,把解码库放进 /usr/lib/codecs目录,就已经可以播放rm了.

聚合内容